Rags 2.4.16 update

By | January 7, 2017

I have a version of the older Rags system I just updated to talk to the new server location.

I had to make several modifications to the older system to get it to work.  I am running it through some more tests but should have the version available soon.

Thanks again for your patience as I get this system back online and begin to make the enhancements and modifications requested.

I am looking into Xamarin as well so we can create native mobile applications quickly and easily.

Thanks

Steve

27 thoughts on “Rags 2.4.16 update

  1. Patrick

    I just bought the 1 year registration, but didn’t get an e-mail with a key. Is this normal? Is it all due to the change of provider? I have version 2.4.16 btw.

    Reply
    1. Profile photo of slanesteveadminslanesteveadmin Post author

      Hi Patrick! There was just a permission issue with the request. I have that resolved now. We should be good going forward.
      I did get your key over to you, so let me know if you have any more problems.

      Thanks,
      Steve

      Reply
  2. Shados

    There doesn’t seem to be a working link for the 2.4 client currently?

    Reply
  3. fg109

    Hi, I used to have this on my computer and played games with it before, but my hard drive failed and I had to reinstall everything. I can no longer play any of the games that I played before on it. If I try to create a game with the designer, this is the error message I get:

    Unable to load the native components of SQL Server Compact corresponding to the ADO.NET provider of version 8080. Install the correct version of SQL Server Compact. Refer to KB article 974247 for more details.

    I am uncertain if I might be missing any required programs for this to work properly. I am quite sure I never had and version of SQL Server Compact before. I have Microsoft .net versions 2.0 to 4.5 installed, which I thought were the only requirements.

    Reply
    1. Profile photo of slanesteveadminslanesteveadmin Post author

      It could be that my new installer is not automatically installing the necessary sql server ce version. Let me look into it and make sure the sql server compact edition dlls are included for the next release. You can always download sql server ce for free as well until I get an updated release out.

      Thanks,
      Steve

      Reply
  4. fg109

    Hi Steve,
    Thanks for looking into it. I forgot to mention it before, but I’m running Windows 7 Professional 64-bit, both before and after my hard drive went bad. I read the article on the Microsoft database and resolved the issue by installing both the x86 and x64 versions of SQL Server CE. I guess that I had both versions installed before, even though I don’t remember doing it.
    BTW, I’m not sure why, but the downloads page does not seem to be showing any updated versions that you may have uploaded. I’ve tried clearing my cache, but everything still looks the same.

    Reply
    1. Profile photo of slanesteveadminslanesteveadmin Post author

      I just updated the latest release to 2.5.2 which should include all the sql server ce files needed for installation. it’s on the download page under the “stable” release.

      Thanks,
      Steve

      Reply
  5. upload2.4.16

    Upload 2.4.16

    we don’t care if it can be registered just upload the player already

    Reply
        1. Profile photo of slanesteveadminslanesteveadmin Post author

          It should…let me see if I can find a few more games to run through it and see what issues I encounter. I will try 2.5.2 with them. Let me know if this is what you used as well.

          Thanks,
          Steve

          Reply
          1. Golan

            I am trying to use RAGS 2.5.2 Player with a game made in RAGS 2.14.6 and it gives an error when I try to open the game.. Could you release the old 2.14.6 player?

  6. Captainskel

    HI Steve,

    I’m having a bit of trouble with my copy of 2.4.16. I recently changed computers and moved my game files over. It wouldn’t let me save my existing game in the designer so I reregistered but the code is giving me the error “sorry rags is unable to communicate with the server”.

    Reply
    1. Profile photo of slanesteveadminslanesteveadmin Post author

      Hi Captain Skel! I just recently updated my host provider. My previous host provider was not providing a stable platform. In order to register, you’ll need to get the latest version of Rags. Version 2.5+ will work with my new provider.

      Thanks,
      Steve

      Reply
  7. Pirate273

    Hello. I’m having a problem finding the 2.4.6 version of Rags. And every time i try opening it with 2.5 and it gives me an error message.

    Reply
  8. Davina

    Could you please post this? I was running 2.5.2 just fine with my purchased account but computer crashed and now 2.5.2 won’t run on my laptop running windows xp. 2.4 will and I need to continue my game asap. Please post a validating copy of 2.4 so I can use the developer since I purchased it. Thank you.

    Reply
    1. Profile photo of slanesteveadminslanesteveadmin Post author

      The older RAGS versions don’t validate to the new server which prompted the latest 2.5+ releases. Can you only run RAGS on a windows XP box? Did you have 2.5.2 running on your windows xp box? Do you have all the latest service packs installed on that box?

      Thanks,
      Steve

      Reply
  9. Dollmistress

    Hi Steve – I am having the same problem as Captain Skel and don’t know how to resolve it. My computer died recently and I had to refresh it, losing lots of programs. RAGs was one of them.

    I have four different RAGs reg keys that I have accumulate dover the years, and when I try any of them on RAGs Designer 2.4.16 I now get a message saying RAGs cannot talk to the server and complete my registration. I am aware this is because of your change in host provider, etc.

    How do I re-register so that I can continue using Designer for my creations? I need 2.4.16, it is the universally-recognised stable version of RAGs that still works with all current and past RAGs games. All later versions of RAGs (including all the ones you’ve recently posted) will not load my in-progress game. All they do is crash upon launch and corrupt the game file I try to load. Please can you email me so we can try to resolve this as until I can get Designer running again I am unable to do any new work on my current game.

    Reply
    1. Profile photo of slanesteveadminslanesteveadmin Post author

      2.5.2 is the replacement version of RAGS that will register to this site. If there are games that are giving you problems with that version, please let me know about them and I can get an updated version released that corrects the issues.

      Thanks,
      Steve

      Reply
      1. Dollmistress

        Okay, I’m trying to give 2.5.2 another go but when I try to register it’s telling me something like “sorry, this key and email combination has not been registered.”

        I’ve tried all four of my keys and none of them work 🙁

        Reply
        1. Profile photo of slanesteveadminslanesteveadmin Post author

          OK, sorry…I didn’t see this reply. Let me check your account real quick and get you set back up properly.

          Thanks,
          Steve

          Reply
        1. Profile photo of slanesteveadminslanesteveadmin Post author

          Just download the install from the download page and register it just like you would 2.4.16. Email me if you have any problems with it.

          Thanks,
          Steve

          Reply
  10. Larry

    Hi Steve,
    This is probably a dull question, but I cannot figure out the right process of updating a licensed verion. Should I simply download the latest rags version and add the license key there? Since I am in the process of developing a game under 2.4.16, could there be problems of continue working on the game with version 2.5.2? or should I continue using 2.4.16?

    Reply
    1. Profile photo of slanesteveadminslanesteveadmin Post author

      It looks like your registered email address in PayPal is incorrect. It bounced back for me. Can you email me the correct address to send the key to?

      Thanks
      Steve

      Reply
      1. koopaphil

        Where can I find your e-mail address? Mine is the address I’m using to post here. It should also be the same as the PayPal account, but nothing is ever easy, is it?

        Reply

Leave a Reply

Your email address will not be published. Required fields are marked *